易语言 csv转xls

CSV也是TXT文本文件~用记事本打开就一目了然了~
写了个子程序,填进去调用就行了~

.版本 2
.子程序 修改CSV数据, 逻辑型
.参数 CSV文件名, 文本型, , 全路径文件名或当前目录内的文件名
.参数 CSV行号, 整数型, , 第几行
.参数 CSV列号, 整数型, , 第几列
.参数 CSV文本, 文本型, , 修改后的数据
.局部变量 CSV文件号, 整数型
.局部变量 Dpos, 整数型
.局部变量 Lpos, 整数型
.局部变量 Cpos, 整数型
.局部变量 Clng, 整数型
.局部变量 char, 字节型
CSV文件号 = 打开文件 (CSV文件名, , )
.如果真 (CSV文件号 = 0)
打开文件失败
返回 (假)
.如果真结束
移到文件首 (CSV文件号)
移动到目标行号
.计次循环首 (CSV行号 - 1, )
读入一行 (CSV文件号)
.如果真 (是否在文件尾 (CSV文件号, 真))
返回 (假)
.如果真结束
处理事件 ()
.计次循环尾 ()
Lpos = 取读写位置 (CSV文件号)
移动到目标列号
char = 0
Dpos = 0
.如果真 (CSV列号 > 1) 当目标列号=1时其实就是在行首
.判断循环首 (char ≠ 13) 是否换行
读入数据 (CSV文件号, char)
.如果真 (char = 44) 到分隔符
Dpos = Dpos + 1
.如果真 (Dpos = CSV列号 - 1)
已经移动到目标列号的位置
跳出循环 ()
.如果真结束
.如果真结束
处理事件 ()
.判断循环尾 ()
.如果真 (char = 13) 到行尾也没有到达目标列号 出错
返回 (假)
.如果真结束
.如果真结束
Cpos = 取读写位置 (CSV文件号) <需要修改的数据的位置
计算数据长度
char = 0
Clng = 0
.判断循环首 (char ≠ 13) 是否换行
读入数据 (CSV文件号, char)
.如果真 (char = 44) 到分隔符 跳出
跳出循环 ()
.如果真结束
Clng = Clng + 1
处理事件 ()
.判断循环尾 ()
开始修改
移动读写位置 (CSV文件号, 1, Cpos)
.如果真 (Clng > 0) 该位置有数据,删除
删除数据 (CSV文件号, Clng)
执行删除操作后读写位置会移动到文件尾部 所以要再移回去
移动读写位置 (CSV文件号, 1, Cpos)
.如果真结束
插入文本 (CSV文件号, CSV文本)
关闭文件 (CSV文件号)
返回 (真)

调用例子:
修改CSV数据 (“CSVTEST.CSV”, 到整数 (编辑框1.内容), 到整数 (编辑框2.内容), 编辑框3.内容)
喜欢阅读
  • 纪少的恃宠娇妻

    纪少的恃宠娇妻

    为了完成母亲临死前千叮咛万嘱咐的遗愿,傅语沉同意替嫁给纪亦泽,谁知大婚后就被父亲傅兴安下了药,一心算盘着自己的退路,一边要想办法让他同意和傅兴安合作……

  • 情意绵绵:许你深情尽余欢

    情意绵绵:许你深情尽余欢

    天色黯淡下来,就是赛车手的天堂。飘雪的冬日,炙热的夏天,天大的恩仇,缠绵的情愫。到底谁是幕后主使,到底是谁在背叛……

  • 霍先生婚后再爱

    霍先生婚后再爱

    为了跟霍靳琛结婚,沈微雨用尽了手段,换来的却只有情敌的挑衅和一纸孕书。她终于忍无可忍决定离婚,冷落了她三年的丈夫冷漠一笑,“除非死,否则你这辈子都别想离婚!”死?不久后,媒体铺天盖地的报道着,霍氏总裁隐婚三年的妻子立下遗嘱,此生不再踏进霍家大门!

  • 强势宠爱:娇妻,乖一点!

    强势宠爱:娇妻,乖一点!

    公司倒闭,父母遇害,商业王国一夜倾塌。她步步为营,讨得他的疯狂宠爱,两人在感情的旋涡中越陷越深……被仇恨蒙蔽双眼的她盗取公司机密,亲手毁了他的公司结果却发现这是一场天大的误会,可大错已铸成……

  • 富可敌国

    富可敌国

    女友因为我穷给我戴了一顶绿帽,却不知家族禁令提前解除,现在的我富可敌国。

  • 美妙心灵·华丽转身

    美妙心灵·华丽转身

    这是关于一个有故事的农村姑娘,只身一人来到大城市北京,努力奋斗、努力工作的励志故事。并且在奋斗的路上,遇见了继父丢失的儿子——宁宁,也就是她青梅竹马的哥哥。他们是如何认出对方的?又是如何最终走在一起?种种疑团都在作品中为您呈现......

  • 血煞仙域

    血煞仙域

    天地浩荡,日月当空,皇天大陆,天骄并起,群雄逐鹿。八年前,少年江枫,被家族弃于妖兽山脉。然,八年后,强势归来,一人一剑,败天骄,压群雄,逆天崛起,制霸五域。圣女?只够资格给我暖床;圣子?只够资格给我背剑!

  • 恐怖殡仪馆

    恐怖殡仪馆

    我叫凌余,跟大胖一起在殡仪馆工作,有一天殡仪馆里来了一具身穿香奈儿的漂亮女尸,我把这套香奈儿偷了回去,送给了女朋友,接着,一连串的邪门事情发生了……接连的死亡,一步步逼近我跟大胖,我们又该如何逃脱死神的追逐?

  • 猜你喜欢
  • xls怎么转换成csv
  • xls转换csv
  • xls转csv
  • csv文档转换成xls
  • 怎么把csv改成xls
  • csv格式转换成xls
  • xls转csv格式工具
  • 怎么把xls转换成csv
  • csv和xls区别
  • xls格式转换成csv格式
  • 热门推荐
  • 现代舞剧白毛女全剧
  • 渡边梨加 哥哥
  • 漫威恶搞动画叫什么
  • 农家小辣妻瑾俞问宁
  • new balance是新百伦吗
  • 维尼琼斯 肌肉
  • 新加坡签证 出行时间
  • 异度之刃2昆虫采集点
  • 日照市公安局王芳简历
  • 按键精灵 弹出提示框
  • qq空间怎么用微信表情
  • cmu计算机排名
  • 互联网商业模式有哪些
  • 小幸运歌曲白静晨下载
  • 以戏剧艺术 舞台艺术
  • 上海浦发银行卡怎么样
  • 辐射4狼帮商店
  • fifa17英超套 中场
  • 已知圆c经过点a(6,0)
  • char 数组作为参数
  • All Right Reserved 安福网